Exercises for Web Design
Dreamweaver CS5

Autumn 2010
## Contents

What? ........................................................................................................................................... 3
Why? ............................................................................................................................................. 3
How? ............................................................................................................................................. 3
Getting started.............................................................................................................................. 4
Adding Images............................................................................................................................... 5
Exercises – how to use Dreamweaver............................................................................................ 6
  Exercise 1 – Creating and uploading a new Website................................................................. 6
    The Structure of Websites ........................................................................................................ 7
  Upload the Website to a Web Server ......................................................................................... 8
Exercises 2 – How to use the Layout Table and the embedded Table ....................................... 9
Exercises 3 – Creating a Website and structuring the Front Page ............................................. 11
  How to use embedded Tables ................................................................................................. 12
Creating a Template ................................................................................................................... 14
  How to use the Template ......................................................................................................... 15
  How to add or change the Template ..................................................................................... 15
Attach the Template to existing Pages ....................................................................................... 16
  How to insert Images with Mouse-over Effects .................................................................. 17
  Another Behavior – Open in a new Browser ........................................................................ 18
What?
In this course you will learn the basic skills to establish and maintain a simple website using Adobe Dreamweaver, which is a standard web authoring tool.

Why?
Because the internet is:
- The largest media on earth
- The fastest growing media on earth
- The most dynamic media on earth
- The cheapest media on earth

How?
All web pages are based on code, such as HTML, PHP and ASP. Making web pages directly in HTML code is rather time consuming and ineffective, and therefore, a variety of web editors are offered by various software companies, e.g. Adobe Dreamweaver.

The way to make a website:
1. Edit the pages on your own computer
2. Upload the pages to a web hotel. This is done by software called FTP (File Transport Protocol). FTP is built into Adobe Dreamweaver. The web hotel will make the website accessible to all internet users.
Getting started
When you open Dreamweaver, you will get the following picture on your screen:

[Image of Dreamweaver interface]

Press HTML to open a new page in the editor and you will get the following picture:

[Image of Dreamweaver new page]

Note that this is how you create a single webpage – later on you will learn how to create a website structured around more than just one page.
On the right-hand side you will see the local files of the websites, which means the files stored on your computer. So far it is empty because we have not made any files yet!

**Adding Images**

In order for Dreamweaver to handle images, you need to copy all the images to the root-folder of your site. Create a subfolder called *images* and put all your images in there. You create a subfolder in Dreamweaver by right-clicking on the pane on the right-hand side and select *New folder*.

Now you can add images by *drag-and-drop* from the pane and into the editing window. When you do this, a box will appear where you can add alternate text. Please, notice that you do not have to name your picture *RELAX* like in the picture below. Name the picture anything you want to!

![Image Tag Accessibility Attributes](image)

If your background colour is not white, you will see that the image has an unwanted white border. You can remove this by using the cropping tool to adjust the frame.

**GRAPHICS**

Stick to the following rules for the best result:

1. All graphics in web pages should be either .gif or .jpg format
2. Use .gif for graphic images – line drawings, images with few colours, logos etc.
3. Use .jpg for Photographic images.
If you want to resize the image you have put onto your webpage, this is done by dragging one of the corner handles – to constrain the proportions hold down the *Shift*-key while dragging. Please notice that all minor size adjustments should be done in this way, as image quality deteriorates.

**Exercises – how to use Dreamweaver**

In the following you will be given some exercises which should give you some experience in using Dreamweaver for web design.

**Exercise 1 – Creating and uploading a new Website**

1. Open Dreamweaver and create a new website

Choose *Create New – Dreamweaver site* like shown above.

2. A guide will start and will ask you to name the site, e.g. *mywebsite*. *(Do not* type in any http address.) Name it and select a location for the site to be saved.

3. Click save.
You have now created a website – but as this point the website only works in Dreamweaver. This means that all renaming and deleting of files should **always** be done in Dreamweaver. Otherwise, the hyperlinks will not work anymore.

You can see the website and the files you will put into it later in the pane in the right-hand side of Dreamweaver.

4. Choose Create New – HTML to create a new page, which is going to be the front page of your website.

5. Save the page in your local web-folder on the M-drive – the front page **must** be named either index.html or default.html.

6. In Properties in the bottom of the screen, click on the button **Page Properties**. Here you can change the background colour, font- and type-size and in **Title/Encoding** you can insert the title of the page, which will be shown in the title line of the browser.

You are now ready to write on the front page on your new website!

**The Structure of Websites**

It is a good idea to take some time to plan your website. The following three questions are useful to consider:

- Who is the audience?
- How does that affect design and functionality?
- What structure do you want?

You should now create a website about yourself containing the following:

---

**Rules for file names for web pages:**

1. The first page should always be named index.htm or default.htm. The browser will always look for one of these files, when directed to a web address.
2. File extensions can be .htm or .html.
3. Only lowercase letters should be used and only letters from a-z and numbers from 0-9. Never use special characters or symbols in filenames. The Danish characters æ, ø and å are considered as special characters as well as “space”, “*”, etc. Underscore
1. The index-page (front page) should contain an introduction in which you describe yourself. Insert an image of yourself, if you have one. You should also make links to the other pages in the website.
2. The hobby-page should contain a short description of three of your hobbies or interests. Insert some fitting pictures.
3. The hyperlink-page should contain external links to three of your favourite web pages.
4. In the study-page you should write about your education.

Save the files in your local web-folder and check that you pictures also appear in the website-folder in the Files-pane.

Upload the Website to a Web Server

You are now going to upload your site to your web-folder so that the pages can be seen on the internet.

1. In the file-pane, choose the icon Connect to remote host.
2. In the display window that appears, click the small plus sign.
3. Another dialog box pops up, and under the Basic tab, drag down the list arrow next to Connect Using: and choose Local / Network. Click the folder icon next to Server Folder and select the W-drive.

4. Click Save and then Save again.
5. Click OK in the dialog box The cache will now be recreated ...
6. A connection should now be established to the web-server and all you need to do is move the website. Click on Put file(s).

Exercise 2 – How to use the Layout Table and the embedded Table

Your assignment is to create a fan page for Robbie Williams, which should look somewhat like this:
Create a table with one column and a fitting number of rows. In the row, where the image should be placed, create an embedded table with two columns and a number of rows. The cells can be merged, if needed.

Find a fitting background pattern, the button and an image of RW on CampusNet. You can copy and insert the text below:

Robert Peter Williams more commonly known as Robbie Williams (born 13 February 1974, Stoke-on-Trent, Staffordshire, England) is a Grammy Award-nominated and multi BRIT Award-winning English singer-songwriter. His career started at the age of 15 as a dancer and singer of the pop band Take That in 1989, which he left in 1995 to launch his solo career. He was raised in Stoke-on-Trent, with a sister, Sally, by Peter and Janet Williams, their parents. He attended Mill Hill Primary School and St Margaret Ward’s Roman Catholic School, Tunstall. As a solo artist, he has sold more albums in the U.K than any other British solo artist in history and has won more BRIT Awards than any other artist to date.
His album sales stands at over 55 million worldwide. Williams entered in The Guinness Book of World Records when he announced his World Tour for 2006, selling 1.6 million tickets in one single day. He has been the recipient of many awards, including ten BRIT and six ECHO awards. In 2004, he was inducted into the UK Music Hall of Fame, after being voted as the Greatest artist of the 1990s. He appears in the list of the all-time Top 100 biggest selling albums in the United Kingdom six times. It is also estimated he is currently the best selling non-Latin artist in Latin America at the moment with over 3 million sold.

Remember to insert paragraphs and change the font and colour.

Insert a button in the bottom of the page with a link to the official Robbie Williams website: http://www.robbiewilliams.com

Remember to change the title of the page under Page Properties. Save the page and preview it by using the F12-button.

Exercise 3 – Creating a Website and structuring the Front Page

Most websites are created by the same table structure, because this makes it easy to control the layout.

Your assignment is to create a website for the wrestling club B-Strong with the same structure as shown above.

© Margit Grønborg
ASB Media, Aarhus School of Business
University of Aarhus

LINKS
There are three basic types of links:
- Internal links – links that makes a jump within the same page
- Local links – links that jump to another page within the same website.
- External links – Links that open a page form a website outside your own.
You can use a string of text or an image as a link
In order to make it a bit easier for you, you can leave out the division between the menus on the left-hand side and the main text. You can put all text into one cell in the table. Below is shown an example of how the website might look like:

![B-Strong](image)

<table>
<thead>
<tr>
<th>About</th>
<th>Contact</th>
<th>Members</th>
<th>Pictures</th>
<th>News</th>
</tr>
</thead>
</table>

Welcome to the Wrestling club B-Strong.

Wrestling is a unique sport in that it provides both physical and mental development. We are a non-profit organization that provides wrestling instruction mainly for youths (girls and boys) ages 4 - 18, but we also have adult members. Our purpose is to support wrestling at all levels, promote the sport to the public and develop amateur athletes for wrestling competition in the local area.

Our emphasis involves the fundamentals that will help each wrestler with physical and mental growth. Our club promotes a safe, positive and friendly atmosphere where those interested in wrestling can learn about the sport. We focus on good sportsmanship, respect for authority and skills needed to achieve success both on and off the mat.

Young wrestlers are encouraged to stay and watch older wrestlers. Viewing the sport at a higher level is an excellent learning tool and provides valuable support for their practice. Public support of B-Strong wrestling club helps us bring opportunities to the youth.

Wrestling club B-Strong - Solsikkevej 8 - 8000 Aarhus C - 86 12 34 56 - contactbstrong.dk - www.b-strong.dk

How to use embedded Tables

1. Create a new, local web folder on the M-drive called B-Strong and then create a new website in Dreamweaver with the same name (see exercise 1). Open a new html-page and save it as index.html.

2. Define text-, hyperlink- and background colour and define font, size, title etc. in Page Properties.

3. Create a table with four rows and one column. The table should be 760 pixels wide.
4. Centre the table – see picture below.

5. In the first row of the table, you should insert a banner. If you have created and saved your banner from Photoshop / image processing module in the last semester can be inserted here - perhaps after a change to the text of B-Strong and regulation of banks. Otherwise you can use the file banner from Campusnet. You might change the background color of the cell to match the colors in the selected banner. Center the picture.

6. In the second row you should make an embedded table with one row and the number of columns equivalent with the number of subtitles you want, e.g. five.

7. Write one of the following link texts in each cell: About, Contact, Members, Pictures and News.
8. Write a short welcome text in the third row. Insert paragraphs where it fits. It could be useful to create an embedded table with one column and one row to control the placing of the contents better.

9. In row four, you should fill in information about the club: Name, address, telephone number, and email address.

10. Save the page and preview it by pressing F12.

Creating a Template

The front page of the website for the wrestling club should be turned into a template so you can use some of the elements for the other pages. This will save you effort and time making the other pages.

1. Open the front page Index and delete the text in the third row. Make a line break in row three, which makes it easier to see the row.

2. Choose File → Save as Template. In the box that appears write standard in the field Save as. Make sure that the correct name for the site B-Strong is written in the field Site. Click Save and then Yes to update the links on the site. The file will now be saved with the extension. Dwt - dreamweaver template.

3. Make the third row the editable field for the new pages. Please, notice that if this is not done, it is impossible to put different content into the different pages. If you want to, you can make several editable fields on the page.

Place the cursor in row three and choose the menu Insert → Template Objects → Editable Region. A box will appear and in the field type in Contents and click OK. It now says Contents twice – delete the lower one to avoid the same text being shown on all pages.

4. Choose File → Save and close the page.

Your template is now set up and in the site manager pane a folder for templates has been created. Your template is called standard.dwt. If you cannot find your template, click on the Update-button in the site manager pane.
How to use the Template
This next page will be made on basis of the new template.

1. Choose File → New and choose your template as shown below:

Make sure that there is a check mark in the field Update page when template changes. Click on the button Create. A new page is created, where you can put in contents in row three – the rest of the rows are closed.

2. Insert the text from the file News on the N-drive. (Open Explorer/Path Finder → right-click on the file → Choose Copy. Go back to Dreamweaver → right-click on the row → Choose Paste → Mark Insert the Contents → OK.) Make some paragraphs, headlines etc. in the text.

3. Save this page as News and preview it in the browser by pressing F12.

How to add or change the Template
If you need to add or change something in the template you will have to do the following:

1. Open the page Standard (File → Open) and make a hyperlink from the field News to the new page called News. If “../” has been added in front of the filename, you have to delete it, before you make the hyperlink.
2. Save the page under the same name. This way the hyperlink will also appear on the page *News* which is made from the template. If the page is open, save it again with the new changes from the template.

**Attach the Template to existing Pages**

The front page *Index* can also become attached to a template, so the changes we make in the template will also appear on the front page.

1. Open the front page and cut the text in row three into the memory (*mark the text and press CTRL+X*)
2. Choose the menu *Modify* → *Templates* → *Apply Template to Page*.
3. Mark the template *Standard* and mark *Update Page* and click *Select*.

4. Click on *Document Body* in the box that appears and choose *Nowhere* in the list in front of *Move to new region*. See picture below.

5. Click on *Document Head* and choose *Head* in the list in front of *Move content to...* Click *OK*.
6. In the *Content Box* paste the text that you saved in the memory (*CTRL+V*).
7. Save the front page (CTRL+S).

How to insert Images with Mouse-over Effects

Many websites have images that change whenever you move the cursor over the picture. This is made from two almost similar images which are switched, when you move the cursor over it. All you have to do is find two images, which are only different in for instance colour or fonts and then add a behavior to the first image, which is also attached to a hyperlink on the same page.

You have to insert one image with mouse-over effect on a page to the website for B-Strong.

1. Find four or six images/drawings of wrestlers on the Internet and download them to the desktop on your computer. The images should be very similar in size, so if necessary change them in Photoshop, before you insert them to the webpage.

2. Create a new page using the template and insert an embedded table with two or three columns and one row.

3. Insert one of the images (Insert → Image) in one of the columns on the newly created page and mark the image. Give the image a fitting name in the empty field on the right-hand side of the miniature image under Properties.

   ![Image Properties](image1.png)

   Also insert “#” or a webpage name in Link and a text in Alt.

4. With the image marked, choose + under Behavior and then choose Swap Image.

5. You now have to define a rollover-image for the named image. Click on the Browse-button and choose the other image of wrestlers. Mark the two fields Preload and Restore. See the picture below for further information.

   ![Swap Image](image2.png)
6. Under **Behavior** you can see two behaviors; **OnMouseOut** and **OnMouseOver**.

7. Insert one or two other images in the same way as above. Remember that the image inserted on the page should be named before adding a behavior.

8. Save the page under the name **Pictures** and preview it in the browser by using **F12**.

9. Open the template **Standard**, add the hyperlinks from the menu **Pictures**, add an email-link to the email address in the bottom row and save the template. Click **Yes** to updating the pages that are based on the template and click **Update and Close**. If any pages are open, save them with the new changes to the template.

**Another Behavior – Open in a new Browser**

From the field **Contact** you have to create a link to a map. The map should be shown in a new browser, which is fitted to the size of the map. Find a map on the Internet or use the one below:
1. Open the template *Standard* and make contact a dead link ("#”). Leave the template open.
2. Create a new html page, but do not use the template. Save the page as *map.html*.
3. On the map page, insert the map you found. Click on *Page Properties* under *Properties*. Set *Left Margin, Right Margin, Top Margin* and *Bottom Margin* to 0. Additionally, you can also setup a background colour and give the page a name.
4. Write Name, Address, Telephone number and Email address on a line under the map. Save and close the page.
5. Return to the open template *Standard* and mark the link Contact (the dead link).
6. Open the panel Behavior, click on + and choose Open Browser Window.
7. Click on the button Browse next to URL to Display and find the page *map.html*. If “../” has been added, make sure you delete it before you make the link.
8. Set Window Width to 420 and Window height to 400 or whatever fit the chosen map and address line. Mark the fields Resize handles and write a name in the field Window name. Click OK.

![Open Browser Window](image)

9. Check that there is only one behavior in the panel: *OnClick Open Browserwindow*.
10. Save and update the pages, which are based on the template.
11. Preview all the pages in a browser – start with the front page (*index page*).

**PDF**

- To make sure that all internet users can open documents from your website it is a good idea to make all files PDFs.
- Any MS Word or MS Excel document can be changed into a PDF file using the program *Cutepdf* – the program can be downloaded from [www.cutepdf.com](http://www.cutepdf.com)